It is currently Tue Mar 26, 2019 5:34 am


All times are UTC [ DST ]


Forum rules


When asking for help, make sure you are using the latest stable version of Daphne with the latest DaphneLoader. "For sale", auction, or ebay links do not belong here. Legal discussion is discouraged.



Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: Serial scoreboard and singe problem
PostPosted: Wed Mar 06, 2019 8:38 pm 
Registered User
Registered  User

Joined: Wed Mar 06, 2019 7:46 pm
Posts: 1
In advance, sorry by my bad inglish... itsn't my natal language.
I modified the code to add the options in the command line "-scoreser" "-scoreport X" (X for comport number) "-scorerate YYYYYY" (YYYYYY for baudrate, is 115200 by default) and thus generate a serial output for a scoreboard with arduino.
I created "SP ScoreBoard.cpp" with the code necessary to make the communication with an arduino via serial port but maintain compatibility with all previous scoreboard modes.

the implemented protocol is:

1st byte (sync byte 0xFF)
2nd byte (sync byte 0xFF)
3 byte - player 1 digit 1
4 byte - player 1 digit 2
5 byte - player 1 digit 3
6 byte - player 1 digit 4
7 byte - player 1 digit 5
8 byte - player 1 digit 6

9 byte - player 1 Lives
10 byte - player 2 Lives
11 byte - credit digit 1
12 byte - credit digit 2

13 byte - player 2 digit 1
14 byte - player 2 digit 2
15 byte - player 2 digit 3
16 byte - player 2 digit 4
17 byte - player 2 digit 5
18 byte - player 2 digit 6

the arduino only receives the stream, finds the bytes of synchronization and accommodates the digits on an LCD screen, LEDs on a MAX7221 or as in my case a screen oled SSD1306.
If you are interested, I have no problems sharing the project.

Now "the problem", when I compile the code ... the daphne.exe works perfectly and maintains all the functions and compatibility with the previous scoreboard. All right ... but the .exe does not recognize the library "singe.dll"
If I copy the singe.dll from the official distribution, everything works fine.
But my singe.dll does not work ... the compilation appears as "correct" but daphne.exe can not load it.
Can someone help me with this?


Top
Offline Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Theme created StylerBB.net