It is currently Wed Aug 21, 2019 4:11 am


All times are UTC [ DST ]


Forum rules


When asking for help, make sure you are using the latest stable version of Daphne with the latest DaphneLoader. "For sale", auction, or ebay links do not belong here. Legal discussion is discouraged.



Post new topic Reply to topic  [ 9 posts ] 
Author Message
 Post subject: Framefile Parse Errors
PostPosted: Fri Sep 08, 2006 1:47 am 
Registered User
Registered  User

Joined: Mon Sep 04, 2006 3:03 pm
Posts: 4
Here is my log. Thanks for any help.

--DAPHNE version 0.99.7
--Command line is: C:\Daphne\daphne.exe bega vldp -framefile C:\Mpeg2\Bega's Battle\framefile.txt
--CPU : GenuineIntel 2750 MHz || Mem : 384 megs
--OS : Windows XP/.NET || Video : ATI MOBILITY RADEON 9000/9100 IGP
Set 640x480 at 32 bpp with flags: 0
Initializing sound system ...
No joysticks detected
Loading ./roms/bega/an05-3 ... 8192 bytes read into memory
Loading ./roms/bega/an04-3 ... 8192 bytes read into memory
Loading ./roms/bega/an03-3 ... 8192 bytes read into memory
Loading ./roms/bega/an02-3 ... 8192 bytes read into memory
Loading ./roms/bega/an01 ... 8192 bytes read into memory
Loading ./roms/bega/an00-3 ... 8192 bytes read into memory
Loading ./roms/bega/an0c ... 8192 bytes read into memory
Loading ./roms/bega/an0b ... 8192 bytes read into memory
Loading ./roms/bega/an0a ... 8192 bytes read into memory
Loading ./roms/bega/an09 ... 8192 bytes read into memory
Loading ./roms/bega/an08 ... 8192 bytes read into memory
Loading ./roms/bega/an07 ... 8192 bytes read into memory
Framefile Parse Error
Expected a number followed by a string, but on line 2, found this: bega.m2v(0x20 0x20 0x62 0x65 0x67 0x61 0x2E 0x6D 0x32 0x76 )
Mpeg Path : C:/Mpeg2/Bega's Battle/
---BEGIN FRAMEFILE CONTENTS---
C:\Mpeg2\Bega's Battle\
bega.m2v


---END FRAMEFILE CONTENTS---
You must specify a -framefile argument when using VLDP.
If you didn't, then this is the problem. :)
Could not initialize laserdisc player!
Shutting down sound system...
Shutting down video display...


Top
Offline Profile  
 
 Post subject: Re: Framefile Parse Errors
PostPosted: Fri Sep 08, 2006 2:41 am 
DAPHNE Team
DAPHNE Team

Joined: Thu Feb 08, 2001 1:00 am
Posts: 908
Location: San Francisco
Kayliebug wrote:
Framefile Parse Error
Expected a number followed by a string, but on line 2, found this: bega.m2v(0x20 0x20 0x62 0x65 0x67 0x61 0x2E 0x6D 0x32 0x76 )

...

---BEGIN FRAMEFILE CONTENTS---
C:\Mpeg2\Bega's Battle\
bega.m2v


You haven't supplied the offset for your framefile. The second line should be a number followed by the name of the m2v. You only have the name. Read the docs for more info on how to create your framefile correctly.


Top
Offline Profile  
 
 Post subject:
PostPosted: Fri Sep 08, 2006 4:24 am 
Registered User
Registered  User

Joined: Sun Aug 27, 2006 10:03 pm
Posts: 10
Location: Fort Worth, Texas
Also, doesn't Daphne not like having spaces in the folder names?

Change the C:\Mpeg2\Bega's Battle\ to something like:

c:\mpeg2\bega

Then make sure you fix everything to point to the new directory.


Top
Offline Profile  
 
 Post subject:
PostPosted: Fri Sep 08, 2006 6:00 am 
DAPHNE Team
DAPHNE Team

Joined: Thu Feb 08, 2001 1:00 am
Posts: 908
Location: San Francisco
Zeppo wrote:
Also, doesn't Daphne not like having spaces in the folder names?


this shouldn't be an issue with 0.99.7


Top
Offline Profile  
 
 Post subject:
PostPosted: Fri Sep 08, 2006 5:51 pm 
Registered User
Registered  User

Joined: Sun Aug 27, 2006 10:03 pm
Posts: 10
Location: Fort Worth, Texas
Ah, ok.
I thought I had read something about that in all my work trying to get daphne going, but wasn't sure.

Thanks for the info.


Top
Offline Profile  
 
 Post subject: Re: Framefile Parse Errors
PostPosted: Wed Jul 17, 2019 10:39 pm 
Registered User
Registered  User

Joined: Wed Jul 17, 2019 10:17 pm
Posts: 0
Hi, new to RetroPie and trying to set up Daphne to play Dragon's Lair. Followed ETA prime's video and think I'm close to having it working. When I start Dragon's Lair in Emulation station/Daphne I get an error that said 'Daphne got an error - read daphne_log.txt'. Looked at log file and it said:

Framefile parse error
Framefile only has 1 line in it. Frame files must have at least 2 lines in it
Mpeg Path : 0

------Begin Framefile contents-------

0

------- End Framefile contents --------

Could not initialize laserdisc player!
shutting down sound system
shutting down video display

Am I missing something like a file, or have to go into a file to edit something to get it to work? Any help would be greatly appreciated - Thanks!


Top
Offline Profile  
 
 Post subject: Re: Framefile Parse Errors
PostPosted: Thu Jul 18, 2019 5:02 pm 
Registered User
Registered  User

Joined: Wed Jul 17, 2019 10:17 pm
Posts: 0
So after doing some reading, looks like framefile = lair.txt My lair.txt doesn't really have anything in it. So would a good place to start be editing that file? Would i just make it:

1st line blank
2nd line "151 lair.m2v"

Would someone at least be able to tell me if I'm on the right track here?


Top
Offline Profile  
 
 Post subject: Re: Framefile Parse Errors
PostPosted: Wed Jul 24, 2019 8:18 pm 
DAPHNE Creator
DAPHNE Creator

Joined: Sat Jan 20, 2001 1:00 am
Posts: 2120
Location: Salt Lake City,Utah, USA
Since you went to the trouble to try to find an answer first, I'll chime in :)

https://www.daphne-emu.com:9443/mediawiki/index.php/Disc2Mpeg#Frame_Files

There's nothing more I will add than what's on that page.

_________________
Check out my cool projects!


Top
Offline Profile  
 
 Post subject: Re: Framefile Parse Errors
PostPosted: Fri Jul 26, 2019 2:07 am 
Registered User
Registered  User

Joined: Wed Jul 17, 2019 10:17 pm
Posts: 0
Got it working - thanks!


Top
Offline Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Theme created StylerBB.net