It is currently Sun Jan 20, 2019 10:59 am


All times are UTC [ DST ]


Forum rules


When asking for help, make sure you are using the latest stable version of Daphne with the latest DaphneLoader. "For sale", auction, or ebay links do not belong here. Legal discussion is discouraged.



Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Dragon's Lair Demo Sound During Coin Up Screen Rev A Roms
PostPosted: Fri May 30, 2014 4:50 am 
DAPHNE Tester
DAPHNE Tester
User avatar

Joined: Sun May 12, 2002 8:37 pm
Posts: 183
Location: Yuma, Arizona
Hi Matt Ownby,

When I was doing some Testing on the Dragon's Lair Rev A Roms while using DAPHNE, I ran into a Strange Problem. With the Option of 2 Coins per Play set, when a Player put in the First Coin during the Demo, the Demo Stops and goes to the Coin per Dirk Screen as it should. But when a Player put in the Second Coin, the Scene stays still Frozen as it should be, but you can hear the Audio playing from the Demo, in the background. While this is happening, a Player can still just press the Start Button and everything plays just fine. Still very Strange to say the lease. Maybe a DAPHNE Bug of some sort.

Here are a couple You Tube Video Clip Links of this Problem happening:

[youtube] https://www.youtube.com/watch?v=qMbnp4NE7aA [/youtube]

[youtube] https://www.youtube.com/watch?v=ibC7vIE00lA [/youtube]

Here is an Example of one of my DAPHNE Logs when this strange Problem happened:

--DAPHNE version 1.0.12
--Command line is: daphne.exe lair_a vldp -framefile C:\Users\lord_victorino\Desktop\DAPHNE\vldp_dl\lair\lair.txt -blank_searches -min_seek_delay 1000 -seek_frames_per_ms 20 -homedir C:\Users\lord_victorino\Desktop\DAPHNE -useoverlaysb 1 -bank 0 11111011 -bank 1 01100111 -sound_buffer 2048 -volume_vldp 64 -x 640 -y 480
--CPU : GenuineIntel 2550 MHz || Mem : 4096 megs
--OS : Windows XP/.NET || Video : Intel(R) HD Graphics
--OpenGL: Compiled In
--RGB2YUV Function: MMX
--Line Blending Function: MMX
--Audio Mixing Function: MMX
Setting alternate home dir:
C:\Users\lord_victorino\Desktop\DAPHNE
Setting sound buffer size to 2048
Setting screen width to 640
Setting screen height to 480
Set 640x480 at 32 bpp with flags: 0
Initializing sound system ...
GI Sound chip initialized at 2000000 Hz
No joysticks detected
Remapping input ...
Loading compressed ROM image dl_a_u1.bin...8192 bytes read.
Loading compressed ROM image dl_a_u2.bin...8192 bytes read.
Loading compressed ROM image dl_a_u3.bin...8192 bytes read.
Loading compressed ROM image dl_a_u4.bin...8192 bytes read.
Loading compressed ROM image dl_a_u5.bin...8192 bytes read.
Framefile parse succeeded. Video/Audio directory is: C:/Users/lord_victorino/Desktop/DAPHNE/vldp_dl/lair/./
YUV overlay is done in software (ie unaccelerated).
Booting ROM ...
Play
LDP : disc is already playing, play command ignored
Play
Unsupported PR-7820 Command Received: e1
Successfully changed speed to 1/1X
Successfully changed speed to 1/1X
Search to 323 received - [25] Attract Mode, Sequence 0 Attract Mode
PR7820: search succeeded
Play
Unsupported PR-7820 Command Received: e1
Search to 306 received - [25] Attract Mode, Sequence 0 Attract Mode
PR7820: search succeeded
LDP NOTE: ignoring seek because we're already on that frame
PR7820: search succeeded
Successfully changed speed to 1/1X
Successfully changed speed to 1/1X
Search to 1424 received - [ 0] Introduction, Sequence 0
PR7820: search succeeded
Play
Search to 1823 received - [ 0] Introduction, Sequence 3
PR7820: search succeeded
Play

Just thought I would let you know.

Yours Truly,

Tony M Victorino

_________________
End of line...


Top
Offline Profile  
 
 Post subject: Re: Dragon's Lair Demo Sound During Coin Up Screen Rev A Rom
PostPosted: Sat May 31, 2014 3:18 pm 
Grizzled Veteran
Grizzled Veteran

Joined: Fri Jun 04, 2004 5:12 am
Posts: 116
Strange. I just tested the Rev A roms on the latest Daphne and it worked fine for me. I inserted 1 coin. Got the instructions screen with no sound. Inserted the 2nd coin, still no sound, then proceeded to hit start and play the game. Everything acted as it should


Top
Offline Profile  
 
 Post subject: Re: Dragon's Lair Demo Sound During Coin Up Screen Rev A Rom
PostPosted: Mon Jun 02, 2014 7:17 am 
DAPHNE Tester
DAPHNE Tester
User avatar

Joined: Sun May 12, 2002 8:37 pm
Posts: 183
Location: Yuma, Arizona
Hi Envisaged0ne,

What version of Daphne are you using? I am using --DAPHNE version 1.0.12. Also what operating System are you using? I am using Windows 7.

Yours Truly,

Tony M Victorino

Envisaged0ne wrote:
Strange. I just tested the Rev A roms on the latest Daphne and it worked fine for me. I inserted 1 coin. Got the instructions screen with no sound. Inserted the 2nd coin, still no sound, then proceeded to hit start and play the game. Everything acted as it should

_________________
End of line...


Top
Offline Profile  
 
 Post subject: Re: Dragon's Lair Demo Sound During Coin Up Screen Rev A Rom
PostPosted: Mon Jun 02, 2014 3:03 pm 
Grizzled Veteran
Grizzled Veteran

Joined: Fri Jun 04, 2004 5:12 am
Posts: 116
Daphne Loader is 1.0-2.2.11. I'm using Windows 7 64 bit


Top
Offline Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Theme created StylerBB.net