It is currently Thu Jun 20, 2019 5:51 am


All times are UTC [ DST ]


Forum rules


When asking for help, make sure you are using the latest stable version of Daphne with the latest DaphneLoader. "For sale", auction, or ebay links do not belong here. Legal discussion is discouraged.



Post new topic Reply to topic  [ 15 posts ] 
Author Message
 Post subject: Failure to start CoreAudio - 10.12 Sierra
PostPosted: Sat Jun 24, 2017 10:30 pm 
Registered User
Registered  User

Joined: Wed May 17, 2006 2:12 pm
Posts: 7
Hello,

I just bought a new iMac and when I transferred all of my Daphne files over, and started up Dragon's Lair and Space Ace to test, the video is playing fine, but there is no audio (to be clear I did transfer my "Sound" folder, and have "Enabled, Prefer Emulated Sounds" selected. When I looked at the log, I can see a line of text that says, "WARNING: Audio device could not be opened: Failed to start CoreAudio: AudioUnitSetProperty (kAudioUnitProperty_SetInputCallback)".

Is this a bug in 10.12? Or do I have a incorrect setting?

Thanks.


Top
Offline Profile  
 
 Post subject: Re: Failure to start CoreAudio - 10.12 Sierra
PostPosted: Sun Jun 25, 2017 2:56 am 
Registered User
Registered  User

Joined: Sat Aug 27, 2016 2:28 pm
Posts: 3
I am having the same issue - no sound in Daphne under OS X Sierra. I reported this several months ago and was checking back to see if anyone had found a fix yet.


Top
Offline Profile  
 
 Post subject: Re: Failure to start CoreAudio - 10.12 Sierra
PostPosted: Sun Jun 25, 2017 5:27 pm 
Registered User
Registered  User

Joined: Wed Nov 03, 2004 9:36 pm
Posts: 23
I'm seeing the same issue here. Late 2011 Macbook Pro, macOS Sierra 10.12.5.

daphne_log.txt follows:

Code:
--DAPHNE version 1.0.0
--Command line is: /Applications/Daphne Loader.app/Contents/MacOS/Daphne.app/Contents/MacOS/Daphne lair vldp -framefile /Volumes/arcade/DAPHNE User Data/vldp/lair/lair.txt -opengl -fullscreen -x 1440 -y 900 -homedir /Volumes/arcade/DAPHNE User Data/ -useoverlaysb 1
--CPU : GenuineIntel 2147 MHz || Mem : 0 megs
--OS : Mac OSX || Video : Unknown video
--OpenGL: Compiled In
--RGB2YUV Function: MMX
--Line Blending Function: MMX
--Audio Mixing Function: MMX
Setting alternate home dir:
/Volumes/arcade/DAPHNE User Data/
Setting screen width to 1440
Setting screen height to 900
WARNING : You have specified an abnormal screen resolution! Normal screen resolutions are:
640 x 480
800 x 600
1024 x 768
1280 x 960
1280 x 1024
1600 x 1200

Set 1440x900 at 32 bpp with flags: 81000003
Initializing sound system ...
WARNING: Audio device could not be opened: Failed to start CoreAudio: AudioUnitSetProperty (kAudioUnitProperty_SetInputCallback)
No joysticks detected
Loading compressed ROM image dl_f2_u1.bin...8192 bytes read.
Loading compressed ROM image dl_f2_u2.bin...8192 bytes read.
Loading compressed ROM image dl_f2_u3.bin...8192 bytes read.
Loading compressed ROM image dl_f2_u4.bin...8192 bytes read.
Framefile parse succeeded. Video/Audio directory is: /Volumes/arcade/DAPHNE User Data/vldp/lair/./
OpenGL v2.0 is supported.
Booting ROM ...
lair : Re-allocated overlay surface (360 x 240)...
Play
LDP : disc is already playing, play command ignored
Play
Display disable received
Search to 323 received - [25] Attract Mode, Sequence 0 Attract Mode
NOTE: converting FPKS from 23976 to 29970. This may be less accurate.
search succeeded d0
Play
Display disable received
Search to 306 received - [25] Attract Mode, Sequence 0 Attract Mode
search succeeded d0
LDP NOTE: ignoring seek because we're already on that frame
search succeeded d0
Search to 1424 received - [ 0] Introduction, Sequence 0
NOTE: converting FPKS from 23976 to 29970. This may be less accurate.
search succeeded d0
Play
Shutting down video display...


I should probably mention that the logfile above was generated from a run using QMC2 as the frontend onto DAPHNE, but the result is the same if I run it directly from the commandline or via DAPHNE Loader.


Top
Offline Profile  
 
 Post subject: Re: Failure to start CoreAudio - 10.12 Sierra
PostPosted: Sat Jul 01, 2017 1:25 am 
Registered User
Registered  User

Joined: Wed May 17, 2006 2:12 pm
Posts: 7
I did a little more digging and came across this post:

http://portingteam.com/files/file/8334-daphne/

The post reads:
"This was created due to a bug in macOS Sierra (and possibly El Capitan) that renders the current (10 year old) Mac OS X beta build of Daphne Loader.app completely silent. This is due to a simple SDL compiling flag missing, but without the original source code, I was forced to create this Daphne multi-launcher.

NOTE: The original compiler of the Mac version of Daphne is long gone, and it looks HIGHLY UNLIKELY that we will ever see an updated build for Mac, so this may be your only hope.

I am marking this port GREEN for all graphics, as the only real prerequisite is OpenGL at this point, and a 10 year old version at that!
Please test and report back your findings..."

and then goes on to say this...

"Known Issues:
No known issues at this stage. Be careful creating further custom launchers for other games, as making an mistake, or an incorrect exe flag can send Daphne into a race state, and lock up your whole computer. This only happened once, and I had multiple Wine servers running (invisibly). Just create one at a time, and base exe flags on my main example (Dragon's Lair 2) inside wrapper."

He goes on to talk about his installation process, etc. But I'm hoping someone here knows what he is referring to "SDL compiling flag missing". I've been using Daphne as long as its been available on the Mac, and I'm hoping someone knows how to update the Mac version to work on the latest operating system. I'm not really interested in using Wineskin to make this work.


Top
Offline Profile  
 
 Post subject: Re: Failure to start CoreAudio - 10.12 Sierra
PostPosted: Mon Jul 03, 2017 2:55 pm 
Registered User
Registered  User

Joined: Wed Nov 03, 2004 9:36 pm
Posts: 23
jackm wrote:
I did a little more digging and came across this post:

http://portingteam.com/files/file/8334-daphne/

The post reads:
"This was created due to a bug in macOS Sierra (and possibly El Capitan) that renders the current (10 year old) Mac OS X beta build of Daphne Loader.app completely silent. This is due to a simple SDL compiling flag missing, but without the original source code, I was forced to create this Daphne multi-launcher.

NOTE: The original compiler of the Mac version of Daphne is long gone, and it looks HIGHLY UNLIKELY that we will ever see an updated build for Mac, so this may be your only hope.

I am marking this port GREEN for all graphics, as the only real prerequisite is OpenGL at this point, and a 10 year old version at that!
Please test and report back your findings..."

and then goes on to say this...

"Known Issues:
No known issues at this stage. Be careful creating further custom launchers for other games, as making an mistake, or an incorrect exe flag can send Daphne into a race state, and lock up your whole computer. This only happened once, and I had multiple Wine servers running (invisibly). Just create one at a time, and base exe flags on my main example (Dragon's Lair 2) inside wrapper."

He goes on to talk about his installation process, etc. But I'm hoping someone here knows what he is referring to "SDL compiling flag missing". I've been using Daphne as long as its been available on the Mac, and I'm hoping someone knows how to update the Mac version to work on the latest operating system. I'm not really interested in using Wineskin to make this work.


WINE... Ugh. At that point, you'd be better off setting up a Windows VM in Virtualbox and running DAPHNE that way.

Matt, I know you're busy with DEXTER, but would it be possible to get a build released that's friendly to Yosemite-on-up systems? Not trying to make demands on your time, but I get that I am making demands on your time by asking for that ;)


Top
Offline Profile  
 
 Post subject: Re: Failure to start CoreAudio - 10.12 Sierra
PostPosted: Tue Jul 25, 2017 5:44 am 
Registered User
Registered  User

Joined: Wed May 17, 2006 2:12 pm
Posts: 7
casm - I finally found the solution. The answer was actually in a previous post under "Technical Support > Problem's With Dragon's Lair > Page 3 ("Bill"'s reply)

=====================================================
...The problem is the ancient version of the SDL Library they are using is incompatible with El Capitan (10.11).
The fix is pretty simple. Download the current 1.x versions of the SDL and SDL Mixer Runtime Frameworks for OSX:

libsdl dot org/download-1.2.php

Copy these into the Frameworks directory in the Daphne.app:
Daphne Loader.app/Contents/MacOS/Daphne.app/Contents/Frameworks

After you've replaced the older versions with the new ones you should be good.
=====================================================

I did this and alas, I have my audio back - and all is well. Playing my favorite games once again.


Top
Offline Profile  
 
 Post subject: Re: Failure to start CoreAudio - 10.12 Sierra
PostPosted: Tue Jul 25, 2017 3:32 pm 
Registered User
Registered  User

Joined: Sat Aug 27, 2016 2:28 pm
Posts: 3
That worked! Thank you so much! I've been stuck on this for a year. Ha!


Top
Offline Profile  
 
 Post subject: Re: Failure to start CoreAudio - 10.12 Sierra
PostPosted: Wed Sep 13, 2017 12:29 pm 
Registered User
Registered  User

Joined: Wed Nov 03, 2004 9:36 pm
Posts: 23
[quote="jackm"]casm - I finally found the solution. The answer was actually in a previous post under "Technical Support > Problem's With Dragon's Lair > Page 3 ("Bill"'s reply)

=====================================================
...The problem is the ancient version of the SDL Library they are using is incompatible with El Capitan (10.11).
The fix is pretty simple. Download the current 1.x versions of the SDL and SDL Mixer Runtime Frameworks for OSX:

libsdl dot org/download-1.2.php

Copy these into the Frameworks directory in the Daphne.app:
Daphne Loader.app/Contents/MacOS/Daphne.app/Contents/Frameworks

After you've replaced the older versions with the new ones you should be good.
=====================================================

I did this and alas, I have my audio back - and all is well. Playing my favorite games once again.[/quote]

*Smacks forehead* I had forgotten that DAPHNE bundles its own versions of SDL and the SDL mixer and basically ignores the ones installed in /Library/Frameworks. Replaced them as suggested above and sound is back in 10.12.6. Jackm, you have my (belated) thanks for the tip :)


Top
Offline Profile  
 
 Post subject: Re: Failure to start CoreAudio - 10.12 Sierra
PostPosted: Thu Sep 14, 2017 1:03 pm 
Dragon's Lair Project Staff
Dragon's Lair Project Staff

Joined: Fri Sep 25, 2015 6:32 pm
Posts: 19
"I did this and alas, I have my audio back"

LOL - Is this an auto-correct for an attempt at "at last"?
'Aw crap, I fixed my audio!'


Top
Offline Profile  
 
 Post subject: Re: Failure to start CoreAudio - 10.12 Sierra
PostPosted: Fri Sep 28, 2018 12:47 pm 
Registered User
Registered  User

Joined: Thu Sep 27, 2018 12:03 pm
Posts: 0
hi,
i am running Daphne on MacOS HighSierra and still have this issues. I have downloaded SDL 1.2 and SDL mixer and pasted them into the daphne frameworks folder. Could someone please tell me what i am doing wrong? all games play fine but zero sound whatsoever.

thanks


Top
Offline Profile  
 
 Post subject: Re: Failure to start CoreAudio - 10.12 Sierra
PostPosted: Sun Jan 27, 2019 5:33 am 
Registered User
Registered  User

Joined: Sun Jan 27, 2019 5:26 am
Posts: 0
Hello,

If you're still having this issue, double check that you are putting the updated SDL files into the correct directory, which is:

Daphne Loader.app/Contents/MacOS/Daphne.app/Contents/Frameworks

My guess is that you're not following that path, you're probably going to Daphne Loader.app/Contents and then into Frameworks because there is an SDL file there as well. However, that's not the one that needs replacing.

Follow this path exactly: Daphne Loader.app/Contents/MacOS/Daphne.app/Contents/Frameworks and make sure you replace TWO files, SDL and SDL mixer.

Good luck.


Top
Offline Profile  
 
 Post subject: Re: Failure to start CoreAudio - 10.12 Sierra
PostPosted: Thu Mar 28, 2019 6:12 pm 
Registered User
Registered  User

Joined: Thu Mar 28, 2019 6:07 pm
Posts: 0
You guys keep talking about some directory structure within "Daphne Loader.app", but I wish someone would explain how to find directories WITHIN an executable app? I have Daphne Loader.app, but it is just that: an app. When you install Daphne on the Mac, you just move the executable into the Applications directory.

Now, Daphne DOES create a User directory, but it doesn't have the filestructure you guys keep talking about. It doesn't have a Contents directory, nor any of the other directories in which you say to install the SDL files. PLUS, the SDL installation doesn't come with SDL mixer, something you say to install into the non-existent Daphne Loader.app directory.

So I'm hopelessly confused with this fix that seems impossible to replicate.


Top
Offline Profile  
 
 Post subject: Re: Failure to start CoreAudio - 10.12 Sierra
PostPosted: Fri Mar 29, 2019 12:25 pm 
Registered User
Registered  User

Joined: Thu Sep 27, 2018 12:03 pm
Posts: 0
you can see inside any application on mac by right clicking and selecting "show package contents"


Top
Offline Profile  
 
 Post subject: Re: Failure to start CoreAudio - 10.12 Sierra
PostPosted: Fri Mar 29, 2019 12:29 pm 
Registered User
Registered  User

Joined: Thu Sep 27, 2018 12:03 pm
Posts: 0
[quote="Shag"]Hello,

If you're still having this issue, double check that you are putting the updated SDL files into the correct directory, which is:

Daphne Loader.app/Contents/MacOS/Daphne.app/Contents/Frameworks

My guess is that you're not following that path, you're probably going to Daphne Loader.app/Contents and then into Frameworks because there is an SDL file there as well. However, that's not the one that needs replacing.

Follow this path exactly: Daphne Loader.app/Contents/MacOS/Daphne.app/Contents/Frameworks and make sure you replace TWO files, SDL and SDL mixer.

Good luck.[/quote]


Wish i got that reply months ago, feel so stupid now. In the end i gave up, installed bootcamp and spent a good couple of months setting up hyperspin. thanks for that though


Top
Offline Profile  
 
 Post subject: Re: Failure to start CoreAudio - 10.12 Sierra
PostPosted: Sat Mar 30, 2019 8:09 pm 
Registered User
Registered  User

Joined: Thu Mar 28, 2019 6:07 pm
Posts: 0
My gosh, thanks so much for the pointer for viewing app contents, AND the original advice on updating SDL. Got it working, although I only had to replace the SDL framework, and not the mixer.

Thanks again!


Top
Offline Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 15 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Theme created StylerBB.net