It is currently Tue Mar 31, 2020 11:48 pm


All times are UTC [ DST ]


Forum rules


When asking for help, make sure you are using the latest stable version of Daphne with the latest DaphneLoader. "For sale", auction, or ebay links do not belong here. Legal discussion is discouraged.



Post new topic Reply to topic  [ 8 posts ] 
Author Message
 Post subject: The basic stuff - Mac OS X
PostPosted: Sun Nov 05, 2006 3:07 am 
Registered User
Registered  User

Joined: Fri May 27, 2005 1:58 am
Posts: 8
Ok. I looked at this project a long time ago... it was too early in development for me. Now we have a new app which seems quite nice. I'd like to be able to test it and give some feedback. I'm an Apple engineer at a newpaper, so I might be able to help somewhat.

I have all the roms, mpegs etc. Here is my current setup:

I have the /Users/admin/DocumentsDAPHNE User Data/ as the root folder.

Inside it are the following folders:

cache
Daphne Loader
daphne_log.txt
DaphneLoaderPrefs.xml
Documentation
Framefiles
LaserDiskPlayer.gif
mpegs
ram
roms
tq-keyboard.jpg

I open the Daphne.app and point to my frame file for astron belt for example. It has this path in it:

/Users/admin/Documents/DAPHNE\ User\ Data/mpegs/AstronBelt
10 astron.m2v

I save my settings and click start.

Daphne errors everytime...

Framefile parse succeeded. Video/Audio directory is: /Users/admin/Documents/DAPHNE/ User/ Data/mpegs/AstronBelt/
Could not open file : /Users/admin/Documents/DAPHNE/ User/ Data/mpegs/AstronBelt/astron.m2v
ldp_vldp::shutdown_player WARNING : sound chip could not be deleted
Could not initialize laserdisc player!
Shutting down sound system...
Shutting down video display...

The path: /Users/admin/Documents/DAPHNE/ User/ Data/mpegs/AstronBelt/astron.m2v is invalid because the spaces in DAPHNE/ User/ Data should be escaped or in quotes, but I can't get it to work even if I add them in to the path.

Can someone give me the easy answer? thanks

_________________
priglmeier
mac os x - daphne port


Top
Offline Profile  
 
 Post subject: changes
PostPosted: Sun Nov 05, 2006 3:12 am 
Registered User
Registered  User

Joined: Fri May 27, 2005 1:58 am
Posts: 8
I changed the framefile for astron belt to this to simplify the path:

/mpegs/AstronBelt
10 astron.m2v

Framefile parse succeeded. Video/Audio directory is: /mpegs/AstronBelt/
Could not open file : /mpegs/AstronBelt/astron.m2v
ldp_vldp::shutdown_player WARNING : sound chip could not be deleted
Could not initialize laserdisc player!
Shutting down sound system...
Shutting down video display...

I continue to get the same errors. I have verified the mpeg file and it is good. :x :x :x

_________________
priglmeier
mac os x - daphne port


Top
Offline Profile  
 
 Post subject: Mac OS X Daphne - paths
PostPosted: Sun Nov 05, 2006 3:19 am 
Registered User
Registered  User

Joined: Fri May 27, 2005 1:58 am
Posts: 8
How is Daphne setup to resolve paths?

Is the root already built in or do I need the full paths? Please give examples if you have the m for the framefiles, etc.

example /mpegs/AstronBelt/astron.m2v

or

/Users/admin/Documents/DAPHNE\ User\ Data/mpegs/AstronBelt/astron.m2v

It would be really, really nice to have a standard set of directoris already setup with the Mac OS X version of Daphne. I would be happy to contribute if I can get this to work.

_________________
priglmeier
mac os x - daphne port


Top
Offline Profile  
 
 Post subject: Re: Mac OS X Daphne - paths
PostPosted: Mon Nov 06, 2006 2:57 am 
DAPHNE Gold Donator
DAPHNE Gold Donator
User avatar

Joined: Wed Sep 27, 2006 11:32 am
Posts: 82
Location: California
priglmeier wrote:
How is Daphne setup to resolve paths?

Is the root already built in or do I need the full paths? Please give examples if you have the m for the framefiles, etc.

example /mpegs/AstronBelt/astron.m2v

or

/Users/admin/Documents/DAPHNE\ User\ Data/mpegs/AstronBelt/astron.m2v

It would be really, really nice to have a standard set of directoris already setup with the Mac OS X version of Daphne. I would be happy to contribute if I can get this to work.


Two things that need to be addressed here:


  • In OSX, is it common for path structures to use two different types of syntax simultaneously mid-way through a path? Look at your posted directory, you have forward and backward folder switches all at once:
    Code:
    /Users/admin/Documents/DAPHNE\ User\ Data/mpegs/AstronBelt/astron.m2v

  • Additionally, you haven't provided your full Daphne Error log. It would be much more helpful to see the entire log to see what your command line structure looks like to better assist you.


If you can clarify these items, I think you'll get an answer to your problem quite quickly. Also, don't forget to make use of the Daphne chat room for realtime support.


Top
Offline Profile  
 
 Post subject:
PostPosted: Tue Nov 07, 2006 3:44 am 
Registered User
Registered  User

Joined: Fri May 27, 2005 1:58 am
Posts: 8
Here is my log:

--DAPHNE version 0.101.12
--Command line is: Daphne.app/Contents/MacOS/Daphne lair vldp -framefile /Users/admin/Documents/DAPHNE User Data/Framefiles/dl_framefile.txt -blank_searches -min_seek_delay 1000 -seek_frames_per_ms 20 -homedir /Users/admin/Documents/DAPHNE User Data -bank 0 11111001 -bank 1 00100111 -sound_buffer 2048 -x 640 -y 480
--CPU : PowerPC G5 (1 cpu) 1800 MHz || Mem : 0 megs
--OS : Mac OSX || Video : Unknown video
Setting alternate home dir:
/Users/admin/Documents/DAPHNE User Data
Setting sound buffer size to 2048
Setting screen width to 640
Setting screen height to 480
Set 640x480 at 32 bpp with flags: 1000004
Initializing sound system ...
GI Sound chip initialized at 2000000 Hz
No joysticks detected
dbg: about to call load_roms()
Loading compressed ROM image dl_f2_u1.bin...8192 bytes read.
Loading compressed ROM image dl_f2_u2.bin...8192 bytes read.
Loading compressed ROM image dl_f2_u3.bin...8192 bytes read.
Loading compressed ROM image dl_f2_u4.bin...8192 bytes read.
Framefile parse succeeded. Video/Audio directory is: /Users/admin/Documents/DAPHNE/ User/ Data/mpegs/DragonsLair/
Could not open file : /Users/admin/Documents/DAPHNE/ User/ Data/mpegs/DragonsLair/Lair.m2v
Could not initialize laserdisc player!
Shutting down sound system...
Shutting down video display...

I am aware of how unix paths work. I am asking how Daphne uses them because it doesn't look correct.

I am wondering why the mpg file will never load on Mac OS X machines according to what I read in the forums. Does anyone actually have this working? If you do, you owe it to others to contribute what works and what doesn't to help the project.

list your: /Users/admin/Documents/DAPHNE User Data/ structure
show an example of the roms directory for: DragonsLair
show an example of the framefile for: DragonsLair
lsit the command line setting form the Daphne app.

thanks

_________________
priglmeier
mac os x - daphne port


Top
Offline Profile  
 
 Post subject:
PostPosted: Tue Nov 07, 2006 5:36 pm 
DAPHNE Creator
DAPHNE Creator

Joined: Sat Jan 20, 2001 1:00 am
Posts: 2125
Location: Salt Lake City,Utah, USA
When in doubt, read the documentation:

http://www.daphne-emu.com/wiki/index.ph ... eFramefile


Top
Offline Profile  
 
 Post subject:
PostPosted: Thu Nov 09, 2006 12:15 am 
Registered User
Registered  User

Joined: Fri May 27, 2005 1:58 am
Posts: 8
Funny. I actually searched for docs and din't see that one.

So to summarize the setup of a Mac OS X machine:

download the daphne.app
launch it once and quit.
It will create the /Users/admin/DocumentsDAPHNE User Data/ as the root folder.
create a mpegs folder in /Users/admin/DocumentsDAPHNE User Data/
create folders for each game. dragonslair for example.
copy the video, audio and framefile to this folder.
Note the names of the files.
name them all the same exccept for the extensions.
lair.mv2
lair.ogg
lair.txt (this is the framefile)

open the framefile in textedit

The first line should be a '.' without the quotes which means it's looking in the current directory.

The second line in this file (from memory) is: '151 lair.mv2'

basically the framefile needs to point to the video file and have the correct name in the text.

thanks

_________________
priglmeier
mac os x - daphne port


Top
Offline Profile  
 
 Post subject:
PostPosted: Thu Nov 09, 2006 7:36 am 
DAPHNE Gold Donator
DAPHNE Gold Donator
User avatar

Joined: Wed Sep 27, 2006 11:32 am
Posts: 82
Location: California
priglmeier wrote:
Funny. I actually searched for docs and din't see that one.

The first line should be a '.' without the quotes which means it's looking in the current directory.

The second line in this file (from memory) is: '151 lair.mv2'

basically the framefile needs to point to the video file and have the correct name in the text.

thanks



Correct. In fact, this structure applies to all versions of Daphne with regards to framefiles; it isn't exclusive to Mac OS systems. I think that was basically the gist of both my and Matt's responses - frame file syntax/setup issues are usually the most common problem for users as many folks forget to configure this file.


Top
Offline Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Theme created StylerBB.net