It is currently Mon May 28, 2018 12:40 am


All times are UTC [ DST ]




Post new topic Reply to topic  [ 13 posts ] 
Author Message
 Post subject: Dragon's Lair seeks 2-3 times instead of 1 time
PostPosted: Fri Jun 17, 2016 3:58 pm 
Registered User
Registered  User

Joined: Tue Jan 26, 2016 6:16 pm
Posts: 5
My Dragon's Lair board set is using the F2 PROMS with an LDV-1000 player. Upon boot-up with Dexter, I watched the attract mode to see at the end of the sequence, the credit slides and how to play were randomly showing up in different sequence. I am linking my OneDrive share that has two videos (heavily compressed) so it is view-able but artifacts are simply because of the compression. The pauses and flashes between slides, same slide are the issue that I am experiencing. One is the end sequence of the attract mode after boot-up and the other is the end sequence after the second play of the attract mode. The videos were encoded via VirtualDub using the Microsoft compression method and they are playable in VLC. Any ideas what could be causing the randomness?

https://1drv.ms/f/s!AtF3bMzzS08Qg819cyYlfhjikCB_yQ


Top
Offline Profile  
 
 Post subject: Re: Dragon's Lair attract sequence randomness..
PostPosted: Fri Jun 17, 2016 5:19 pm 
DAPHNE Team
DAPHNE Team

Joined: Fri Jul 27, 2001 1:00 am
Posts: 292
Wow, I haven't seen a video with the MS Video 1 codec since the days of postage stamp-sized clips on a 2X CD-ROM drive... Thanks for the tip to play it in VLC. :)

I haven't seen that specific problem before, but a few things come to mind:

1. Prior to installing Dexter, was the game working properly with an LD-V1000 or conversion card in LD-V1000 mode? If so, it rules out a number of issues. If not, there are several things that have to match for everything to work correctly:
- Game PCB revision (A, A modified for LD-V1000, C)
- Player type DIP switch settings (for specific ROM revision in use)
- "W1" jumper on rev C game PCB (wire installed for PR-7820, no wire for LD-V1000)
- Dexter mode selection (LD-V1000 or PR-7820)

2. Re-seat the interface cable on both ends. Look for bent/broken pins on the end that connects to the game PCB. (A missing bit on the data bus could cause it to get confused about where to search and what frame is being displayed.)

3. Hold down the MODE switch on Dexter for 2+ seconds. This will put it into auto-detect mode, and it will choose LD-V1000 or PR-7820 mode depending on what it sees from the game PCB.

I hope this helps!


Top
Offline Profile  
 
 Post subject: Re: Dragon's Lair attract sequence randomness..
PostPosted: Sat Jun 18, 2016 2:59 am 
Registered User
Registered  User

Joined: Tue Jan 26, 2016 6:16 pm
Posts: 5
Thanks Warren!

Recently my original centronics cable that connects to the logic board and the LDV-1000 was damaged while testing another logic board, so I ordered 2 new cables from a respected seller so I could have an extra. When they arrived, I immediately used one of them to connect my Dragon's Lair to Dexter. The cable turned out to be the issue!

Since you mentioned the interface cable, I unplugged it and tried the second new cable. The second one works fine! Thanks again for the quick suggestions!!


Top
Offline Profile  
 
 Post subject: Re: Dragon's Lair seeks 2-3 times instead of 1 time
PostPosted: Sat Jul 23, 2016 6:03 am 
Registered User
Registered  User

Joined: Tue Jan 05, 2016 5:23 pm
Posts: 6
I have a similar issue with my space ace.

whether I run it with the disk player 7800 or the dexter

it plays 3 frames paused first before it lets the video run
this is for kill scenes or going to the next level
or even for attract mode.
3 pauses. then plays

is that the ROM doing this?

I think I have rev a


Top
Offline Profile  
 
 Post subject: Re: Dragon's Lair seeks 2-3 times instead of 1 time
PostPosted: Sat Jul 23, 2016 6:50 am 
DAPHNE Creator
DAPHNE Creator

Joined: Sat Jan 20, 2001 1:00 am
Posts: 2108
Location: Salt Lake City,Utah, USA
a1max1 wrote:
I have a similar issue with my space ace.

whether I run it with the disk player 7800 or the dexter

it plays 3 frames paused first before it lets the video run
this is for kill scenes or going to the next level
or even for attract mode.
3 pauses. then plays

is that the ROM doing this?

I think I have rev a


It sounds like you may have the dragon's lair dip switches set to LD-V1000 instead of PR-7820. Check the dip switch settings to make sure PR-7820 is enabled and make sure Dexter is also in PR-7820 mode.

_________________
Check out my cool projects!


Top
Offline Profile  
 
 Post subject: Re: Dragon's Lair seeks 2-3 times instead of 1 time
PostPosted: Mon Jul 25, 2016 6:42 am 
Registered User
Registered  User

Joined: Tue Jan 05, 2016 5:23 pm
Posts: 6
I tried the rom settings.
makes it just go to black screen and will not boot up the game.
any other suggestions?


Top
Offline Profile  
 
 Post subject: Re: Dragon's Lair seeks 2-3 times instead of 1 time
PostPosted: Mon Jul 25, 2016 7:02 pm 
DAPHNE Creator
DAPHNE Creator

Joined: Sat Jan 20, 2001 1:00 am
Posts: 2108
Location: Salt Lake City,Utah, USA
a1max1 wrote:
I tried the rom settings.
makes it just go to black screen and will not boot up the game.
any other suggestions?


Can we get a photo of your current dip switches so we can see if there's anything else out of the ordinary about them? I believe that you can attach images to forum posts.

_________________
Check out my cool projects!


Top
Offline Profile  
 
 Post subject: Re: Dragon's Lair seeks 2-3 times instead of 1 time
PostPosted: Wed Jul 27, 2016 2:28 am 
Registered User
Registered  User

Joined: Tue Jan 05, 2016 5:23 pm
Posts: 6
I played with the dip settings. still has the issue. trying to get it to use 7820 doesn't work. video never comes up. yes - I used mode button on dexter to move the light to 7820
always just a black screen.

when I use 1000 it works. but it does the 3 seeks before each scene play.

my dip settings are attached.
and a video of what is happening


Top
Offline Profile  
 
 Post subject: Re: Dragon's Lair seeks 2-3 times instead of 1 time
PostPosted: Wed Jul 27, 2016 2:29 am 
Registered User
Registered  User

Joined: Tue Jan 05, 2016 5:23 pm
Posts: 6
try these links for images

https://drive.google.com/file/d/1RRgwPk ... sp=sharing

https://drive.google.com/file/d/1v0E0wc ... sp=sharing


Top
Offline Profile  
 
 Post subject: Re: Dragon's Lair seeks 2-3 times instead of 1 time
PostPosted: Wed Jul 27, 2016 4:39 am 
DAPHNE Creator
DAPHNE Creator

Joined: Sat Jan 20, 2001 1:00 am
Posts: 2108
Location: Salt Lake City,Utah, USA
a1max1 wrote:


Thanks for the video and picture. This is very helpful.

It appears to me that you have a rev C board because of the presence of the W1 jumper on the bottom middle of the board. This means that you have to run in LD-V1000 mode without modifying your hardware. So I would stick with LD-V1000 mode.

Most likely replacing the ribbon cable that goes from the Dragon's Lair board to Dexter will fix the problem. Shaun Wood sells new ones. I will point him to this thread.

The issue is that the ROM isn't getting back a "search succeeded" code from Dexter so it is retrying the search. A flaky cable can cause this.

_________________
Check out my cool projects!


Top
Offline Profile  
 
 Post subject: Re: Dragon's Lair seeks 2-3 times instead of 1 time
PostPosted: Wed Jul 27, 2016 4:54 am 
Registered User
Registered  User

Joined: Tue Jan 05, 2016 5:23 pm
Posts: 6
ill try my DL cable...


Top
Offline Profile  
 
 Post subject: Re: Dragon's Lair seeks 2-3 times instead of 1 time
PostPosted: Thu Jul 28, 2016 12:55 pm 
Registered User
Registered  User

Joined: Tue Jan 05, 2016 5:23 pm
Posts: 6
it was the wire!

now how do I get a new one?


Top
Offline Profile  
 
 Post subject: Re: Dragon's Lair seeks 2-3 times instead of 1 time
PostPosted: Thu Jul 28, 2016 3:18 pm 
DAPHNE Team
DAPHNE Team

Joined: Fri Jul 27, 2001 1:00 am
Posts: 292
Great! :)

You should be able to get a new cable from Shaun Wood:

http://wood1st.com/LaserCon/Extras/


Top
Offline Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 13 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Theme created StylerBB.net