It is currently Sat Jul 21, 2018 1:03 am


All times are UTC [ DST ]




Post new topic Reply to topic  [ 19 posts ] 
Author Message
 Post subject: Dexter with Hi Tech card, & Limited Edition ROMs
PostPosted: Sun Oct 30, 2016 12:08 am 
Registered User
Registered  User

Joined: Tue Feb 16, 2016 3:21 am
Posts: 10
Hello, Matt. I have a problem with Dexter not booting up in my Dragon's Lair cabinet. I am wondering if this could have something to do with the limited edition laser disc ROMs I installed with the Hi Tech card to run a Sony LDP 1450? I saw a video where someone tested it with the Hi Tech card, & it played fine. However they didn't mention if they were running any updated ROMs. I understand there was also a problem with a certain power supply that was shipped? Mine doesn't appear to be the one pictured, but perhaps that could be my issue? What do you think could be the problem here? Please let me know, & thanks!


Top
Offline Profile  
 
 Post subject: Re: Dexter with Hi Tech card, & Limited Edition ROMs
PostPosted: Sun Oct 30, 2016 5:30 am 
DAPHNE Creator
DAPHNE Creator

Joined: Sat Jan 20, 2001 1:00 am
Posts: 2115
Location: Salt Lake City,Utah, USA
droidsattack wrote:
Hello, Matt. I have a problem with Dexter not booting up in my Dragon's Lair cabinet. I am wondering if this could have something to do with the limited edition laser disc ROMs I installed with the Hi Tech card to run a Sony LDP 1450? I saw a video where someone tested it with the Hi Tech card, & it played fine. However they didn't mention if they were running any updated ROMs. I understand there was also a problem with a certain power supply that was shipped? Mine doesn't appear to be the one pictured, but perhaps that could be my issue? What do you think could be the problem here? Please let me know, & thanks!


hi,

First of all, while it is possible to use Dexter with the Hi-Tech card, the "proper" way to use Dexter is to remove the Hi-Tech card and plug the Dragon's Lair laserdisc cable that was plugged into the Hi-Tech card directly into Dexter instead. Then the only thing left to figure out is whether your Dragon's LAir boardset is set up for PR-7820 or LD-V1000 mode (Dexter can auto-detect this).

However, if you'd prefer to keep using the Hi-Tech card, then you will need to switch Dexter to LDP-1450 mode and plug the hi-tech card into Dexter's DB25 port (the same one as found on a real LDP-1450).

If what I've provided you doesn't help, providing us with pictures of your setup and/or providing an internet connection to your Dexter unit so that I can remotely see what's going on are the next logical steps in my mind.

--Matt

_________________
Check out my cool projects!


Top
Offline Profile  
 
 Post subject: Re: Dexter with Hi Tech card, & Limited Edition ROMs
PostPosted: Fri Nov 04, 2016 12:05 am 
Registered User
Registered  User

Joined: Tue Feb 16, 2016 3:21 am
Posts: 10
Alright, I bypassed the Hi-tech card, & got an error message on the screen. Before I could begin reading it, I lost picture. There was the series of "beeps" followed by the final "boop," & then no sound. I rebooted it in the PR-7820 mode, & got nothing. I rebooted it in the LDP-1450 & got nothing. While it was on, I manually cycled back to the LD-V1000 mode, & got the same "beeps/boop" & then the attract mode came on! I went to the front of the machine, & unfortunately there was still no picture. I reseated the video connection, but no luck there, & the machine made no further sounds. I may have developed a monitor issue during the operation. Does this behavior sound correct to you?


Top
Offline Profile  
 
 Post subject: Re: Dexter with Hi Tech card, & Limited Edition ROMs
PostPosted: Fri Nov 04, 2016 12:37 am 
DAPHNE Creator
DAPHNE Creator

Joined: Sat Jan 20, 2001 1:00 am
Posts: 2115
Location: Salt Lake City,Utah, USA
droidsattack wrote:
Alright, I bypassed the Hi-tech card, & got an error message on the screen. Before I could begin reading it, I lost picture. There was the series of "beeps" followed by the final "boop," & then no sound. I rebooted it in the PR-7820 mode, & got nothing. I rebooted it in the LDP-1450 & got nothing. While it was on, I manually cycled back to the LD-V1000 mode, & got the same "beeps/boop" & then the attract mode came on! I went to the front of the machine, & unfortunately there was still no picture. I reseated the video connection, but no luck there, & the machine made no further sounds. I may have developed a monitor issue during the operation. Does this behavior sound correct to you?


Does the attract mode loop properly (even if you get no picture) ? In other words, does the attract mode restart after it has finished?

If so, dexter is probably working correctly and it's a monitor/ntsc card issue.

_________________
Check out my cool projects!


Top
Offline Profile  
 
 Post subject: Re: Dexter with Hi Tech card, & Limited Edition ROMs
PostPosted: Fri Nov 04, 2016 7:01 am 
Registered User
Registered  User

Joined: Tue Feb 16, 2016 3:21 am
Posts: 10
I only heard it play once. I waited awhile to hear if it looped, but it did not.


Top
Offline Profile  
 
 Post subject: Re: Dexter with Hi Tech card, & Limited Edition ROMs
PostPosted: Fri Nov 04, 2016 5:42 pm 
DAPHNE Creator
DAPHNE Creator

Joined: Sat Jan 20, 2001 1:00 am
Posts: 2115
Location: Salt Lake City,Utah, USA
droidsattack wrote:
I only heard it play once. I waited awhile to hear if it looped, but it did not.


Hmmm... I don't know what to make of that. Are you able to provide an internet connection to the Dexter unit while the game is running? (as shown in the following video)


_________________
Check out my cool projects!


Top
Offline Profile  
 
 Post subject: Re: Dexter with Hi Tech card, & Limited Edition ROMs
PostPosted: Fri Nov 04, 2016 11:48 pm 
Registered User
Registered  User

Joined: Tue Feb 16, 2016 3:21 am
Posts: 10
I will try when I'm back in town next week. Thank you, Matt.


Top
Offline Profile  
 
 Post subject: Re: Dexter with Hi Tech card, & Limited Edition ROMs
PostPosted: Sat Nov 05, 2016 6:05 pm 
Dragon's Lair Project Staff
Dragon's Lair Project Staff

Joined: Fri Sep 25, 2015 6:32 pm
Posts: 15
I'm not positive, but what I think Matt meant to ask is: Does the attract mode run normally, or does Dexter continue to play through the whole laserdisc file after the attract demo is done playing?

If you are using the DLE ROMs, and you heard the attract sound once and then you heard nothing else, then most likely your DIP switch for the attract sound is set to play audio only 1 out of 8 times, and you didnt keep it turned on long enough for 8 loops. If so, your descriptions do not suggest any Dexter problem so far. You would need to either wait for 7 minutes to hear the attract sound again, or change the DIP switch to play the sound every time, in order to confirm that it's looping normally, and then you can focus on a monitor/NTSC/video cable problem.


Top
Offline Profile  
 
 Post subject: Re: Dexter with Hi Tech card, & Limited Edition ROMs
PostPosted: Sun Nov 06, 2016 4:19 am 
Registered User
Registered  User

Joined: Tue Feb 16, 2016 3:21 am
Posts: 10
Cool, good point. I'll try it again when I'm back in town. Thanks!


Top
Offline Profile  
 
 Post subject: Re: Dexter with Hi Tech card, & Limited Edition ROMs
PostPosted: Fri Nov 11, 2016 10:40 pm 
Registered User
Registered  User

Joined: Tue Feb 16, 2016 3:21 am
Posts: 10
Alright, I'm back at it. I still have no picture, but I have a technician coming tomorrow to address that. Hopefully we'll get a visual for what is happening soon.

I played around some more with booting the machine up to hear if the attract sound loops after seven minutes.

On my first attempt I powered both the machine & the Dexter up at the same time. I got the two beeps, & the boop. Then nothing.

On my second attempt I again powered both the machine & the Dexter up at the same time. After the same beeps & boop, I manually selected through the mode switch back to the LD-V1000. Still nothing.

On my third attempt I powered the machine on first, & then I powered up the Dexter. I heard the beeps & boop, then the attract mode started. However this time, it cycled through repetitively where before it only played through once.

Hopefully we'll have visual restored tomorrow, but for now does my description of the boot order & attract mode audio sound like normal function?


Top
Offline Profile  
 
 Post subject: Re: Dexter with Hi Tech card, & Limited Edition ROMs
PostPosted: Sat Nov 12, 2016 5:25 pm 
DAPHNE Creator
DAPHNE Creator

Joined: Sat Jan 20, 2001 1:00 am
Posts: 2115
Location: Salt Lake City,Utah, USA
droidsattack wrote:
Hopefully we'll have visual restored tomorrow, but for now does my description of the boot order & attract mode audio sound like normal function?


It may be normal, but I'd still like to take a peek at your logs via the internet connection to make sure. Is that still a possibility? I want to understand why powering them both on at the same time was not working.

_________________
Check out my cool projects!


Top
Offline Profile  
 
 Post subject: Re: Dexter with Hi Tech card, & Limited Edition ROMs
PostPosted: Mon Nov 14, 2016 10:14 pm 
Registered User
Registered  User

Joined: Tue Feb 16, 2016 3:21 am
Posts: 10
Alright, my tech successfully restored the visual on Dragon's Lair, so now I can see what is happening when we boot the machine & the Dexter up at the same time. The game does not boot up, but instead displays a message. The screen isn't very crisp, but perhaps you can make the text out in this photo?

Image

When I boot the machine first, & the Dexter second, the Dexter cycles through a bunch of images, then the game starts & is playable. However, a frame display is visible in the top left. I assume that is something I can change in a settings menu?


Top
Offline Profile  
 
 Post subject: Re: Dexter with Hi Tech card, & Limited Edition ROMs
PostPosted: Tue Nov 15, 2016 12:26 am 
DAPHNE Creator
DAPHNE Creator

Joined: Sat Jan 20, 2001 1:00 am
Posts: 2115
Location: Salt Lake City,Utah, USA
droidsattack wrote:
Alright, my tech successfully restored the visual on Dragon's Lair, so now I can see what is happening when we boot the machine & the Dexter up at the same time. The game does not boot up, but instead displays a message. The screen isn't very crisp, but perhaps you can make the text out in this photo?


Interesting. I don't currently see how this is related to whether Dexter is started up with the machine or after the machine. My advice remains the same as before to troubleshoot this issue.

_________________
Check out my cool projects!


Top
Offline Profile  
 
 Post subject: Re: Dexter with Hi Tech card, & Limited Edition ROMs
PostPosted: Tue Nov 15, 2016 2:17 am 
Registered User
Registered  User

Joined: Tue Feb 16, 2016 3:21 am
Posts: 10
Okay, let's give it a go. Thank you.


Top
Offline Profile  
 
 Post subject: Re: Dexter with Hi Tech card, & Limited Edition ROMs
PostPosted: Tue Nov 15, 2016 2:54 am 
DAPHNE Creator
DAPHNE Creator

Joined: Sat Jan 20, 2001 1:00 am
Posts: 2115
Location: Salt Lake City,Utah, USA
droidsattack wrote:
Okay, let's give it a go. Thank you.


what is your schedule like? I often hang out in the Daphne Chat Room. We can set something up there when you get a spare moment.

_________________
Check out my cool projects!


Top
Offline Profile  
 
 Post subject: Re: Dexter with Hi Tech card, & Limited Edition ROMs
PostPosted: Tue Nov 15, 2016 1:47 pm 
DAPHNE Team
DAPHNE Team

Joined: Fri Jul 27, 2001 1:00 am
Posts: 292
I suspect a bad Raspberry Pi, or a bad SD card. The "Bus error" message in your screen pic should never appear under normal circumstances.

This doesn't explain why it works when you power up Dexter after the game instead of at the same time, though. Any chance you're using the dreaded Omnihil power supply?

http://my-cool-projects.blogspot.com/2016/05/dexter-power-supply-problem-found.html


Top
Offline Profile  
 
 Post subject: Re: Dexter with Hi Tech card, & Limited Edition ROMs
PostPosted: Wed Nov 16, 2016 3:20 pm 
Registered User
Registered  User

Joined: Tue Feb 16, 2016 3:21 am
Posts: 10
My schedule is a little tight this week, so troubleshooting might have to wait until next week at this point. The power supply I have does not look like the one pictured. I'll try that chat room link & set up a time to work on it with as soon as I'm able. Thank you guys so much for the help!


Top
Offline Profile  
 
 Post subject: Re: Dexter with Hi Tech card, & Limited Edition ROMs
PostPosted: Sun Nov 20, 2016 9:04 am 
Registered User
Registered  User

Joined: Tue Feb 16, 2016 3:21 am
Posts: 10
Well, this is crazy. For some reason, the Dexter is booting up perfectly now. I have no idea what (if anything) changed in it's operation, but for the past three days it has powered up successfully in sych with the machine. It's good timing too, because today I brought the machine over to our local library (along with several other machines from my collection) for International Game Day. I did a presentation on obsolete technology, & showcased DL's laser disc player for one of the examples. The best part of the show for me was teaching some interested kids how to play through the various stages. One kid didn't want to stop, & his mother had to pull him away from it once the library was closing! I figured you guys might appreciate that!

Image


Top
Offline Profile  
 
 Post subject: Re: Dexter with Hi Tech card, & Limited Edition ROMs
PostPosted: Tue Nov 22, 2016 5:16 am 
DAPHNE Creator
DAPHNE Creator

Joined: Sat Jan 20, 2001 1:00 am
Posts: 2115
Location: Salt Lake City,Utah, USA
droidsattack wrote:
Well, this is crazy. For some reason, the Dexter is booting up perfectly now. I have no idea what (if anything) changed in it's operation, but for the past three days it has powered up successfully in sych with the machine. It's good timing too, because today I brought the machine over to our local library (along with several other machines from my collection) for International Game Day. I did a presentation on obsolete technology, & showcased DL's laser disc player for one of the examples. The best part of the show for me was teaching some interested kids how to play through the various stages. One kid didn't want to stop, & his mother had to pull him away from it once the library was closing! I figured you guys might appreciate that!

Image


awesome!

_________________
Check out my cool projects!


Top
Offline Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 19 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Theme created StylerBB.net