It is currently Sat Dec 03, 2022 10:22 pm


All times are UTC [ DST ]


Forum rules


When asking for help, make sure you are using the latest stable version of Daphne with the latest DaphneLoader. "For sale", auction, or ebay links do not belong here. Legal discussion is discouraged.



Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Building on PS3
PostPosted: Fri May 02, 2008 9:52 pm 
Registered User
Registered  User

Joined: Wed Nov 03, 2004 9:36 pm
Posts: 23
Hey everyone - been quite a while since I've looked at Daphne, and am *really* impressed with how things are going. Anyway, on to my problem...

I'm trying to get 1.0 Beta to build under Yellowdog 6 on a PS3. This presents some challenges, since YDL doesn't support OpenGL - but SDL should work fine. However, it isn't ;)

Anyway, before I start dumping build errors, etc., to the forums, is there a more appropriate place to do so? Thanks!


Top
Offline Profile  
 
 Post subject:
PostPosted: Sat May 03, 2008 6:08 pm 
DAPHNE Creator
DAPHNE Creator

Joined: Sat Jan 20, 2001 1:00 am
Posts: 2127
Location: Salt Lake City,Utah, USA
Make sure you're using the source code from here:
http://www.daphne-emu.com/download/daph ... src.tar.gz

This link isn't on the site at the moment, which is why I'm posting it here.

I broke a lot of things in the SVN trunk when I started my rewrite of the video system. The pieces haven't been put back together. So you don't want to use the SVN trunk.


Top
Offline Profile  
 
 Post subject:
PostPosted: Sat May 03, 2008 7:46 pm 
Registered User
Registered  User

Joined: Wed Nov 03, 2004 9:36 pm
Posts: 23
Ah, OK, cool. Thanks. I'll pull it down on that machine and see how it does.


Top
Offline Profile  
 
 Post subject:
PostPosted: Sun May 04, 2008 12:20 pm 
Registered User
Registered  User

Joined: Wed Nov 03, 2004 9:36 pm
Posts: 23
Well, I'm happy to report mixed results ;)

I've got a somewhat working daphne.bin built with only tweaking of the makefiles to suit the Cell architecture and the VLDP compiled statically. I can post the makefiles later, but for now the rough procedure goes something like this:

- Copy ${sourceroot}/src/Makefile.vars.linux_x86 to Makefile.vars.linux_ps3; symlink the latter to Makefile.vars
- Remove any references to MMX, OpenGL, or x86-specific optimizations from Makefile.vars
- cd to ${sourceroot}/src/vldp2; copy Makefile.linux to Makefile.ps3
- Remove any references to MMX or x86-specific optimizations from Makefile.ps3
- ./configure && make -f Makefile.ps3
- cd ..
- make

Assuming all the correct libraries, etc. are installed, this should ultimately leave a daphne.bin with statically-linked VLDP capable of running on a PS3-based Linux in ${sourceroot}.


Quick notes:

Build was with gcc 4.1.1 under Yellowdog 6. SDL, Ogg, Vorbis, etc. libraries were whatever was pulled down via yum.

OpenGL support was disabled since there's currently neither full nor supported access to the PS3's RSX. Linux graphics are currently framebuffer-only on the PS3, so SDL it is.

Video mode is 1080p at 60Hz.


Status:

- 'lair': runs and plays. Audio seems to be restricted to only the samples; sound from the MPEG doesn't play at all. Need to pull error log.

- 'mach3': gets past video parsing, but exits with a blank screen. Textmode video is not restored after this point; I have to shell into the PS3 and reboot it to get video back (no daphne.bin process is showing). Same thing seems to happen if -fullscreen is specified with other games. Need to pull error log.

I haven't tried much else at this point since it's late and I really need some sleep. I did catch a couple of missed x86-specific options in places, so will remove those tomorrow and see how it goes.

For some reason if daphne is built with the VLDP as a dynamic library, it's never found at runtime. Not sure what's going on with that; I've tried repositioning the library in relation to the binary, putting it in different places, etc. For some reason only statically linking it seems to be consistent in terms of allowing the binary to run.


Top
Offline Profile  
 
 Post subject:
PostPosted: Mon Jul 07, 2008 5:09 pm 
DAPHNE Team
DAPHNE Team
User avatar

Joined: Thu Jul 13, 2006 7:51 pm
Posts: 202
Have you made anymore progress? I might try compiling from source if I get rained out of some of my activities.


Top
Offline Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Theme created StylerBB.net