It is currently Tue Jan 23, 2018 6:46 pm


All times are UTC [ DST ]




Post new topic Reply to topic  [ 8 posts ] 
Author Message
 Post subject: Wont run on Ubuntu Gusty
PostPosted: Fri Nov 16, 2007 6:28 am 
DAPHNE Platinum Donator
DAPHNE Platinum Donator
User avatar

Joined: Wed Jan 31, 2007 3:26 am
Posts: 49
Location: Austin, Tx.
Installation on Ubuntu Feisty worked fine. After an upgrade to Gusty, daphne still worked fine. But when I installed Gusty from scratch and tried to run daphneloader and daphne, neither would work. When running daphne directly, it would complain that the ogg wasn't in stereo and that the game would play with no sound. However, this took a very long time and I had to killed it. I never saw the game play with or without sound. I've since returned to Feisty but I really want to figure this out so I'll try again on another box soon. If anyone has a suggestion, let me know.


Top
Offline Profile  
 
 Post subject:
PostPosted: Fri Nov 16, 2007 1:41 pm 
DAPHNE Platinum Donator
DAPHNE Platinum Donator
User avatar

Joined: Wed Jan 31, 2007 3:26 am
Posts: 49
Location: Austin, Tx.
Code:
DaphneLoader Launcher : Script dir is .

DaphneLoader failed to start.
Check to make sure that you have the following libraries installed:
  GTK v2
  SDL v1.2
You _may_ need g++ 3.4 installed.

And daphneloader.bin simply exits, obviously with error code 127. GTK and SDL are installed as well as g++ 3.4.


Top
Offline Profile  
 
 Post subject:
PostPosted: Fri Nov 16, 2007 5:34 pm 
DAPHNE Creator
DAPHNE Creator

Joined: Sat Jan 20, 2001 1:00 am
Posts: 2098
Location: Salt Lake City,Utah, USA
I just did a fresh install of Gutsy and DaphneLoader ran just fine.

What happens when you do "ldd daphneloader.bin" ? Does it say that it's not a dynamic executable? If so, re-download the v1.0 beta for linux from this site and try again.


Top
Offline Profile  
 
 Post subject: Yup!
PostPosted: Sat Nov 17, 2007 2:09 am 
DAPHNE Platinum Donator
DAPHNE Platinum Donator
User avatar

Joined: Wed Jan 31, 2007 3:26 am
Posts: 49
Location: Austin, Tx.
Code:
ldd daphneloader.bin
        not a dynamic executable


That did the trick. I had this version of Daphne copied to a DVD. It would copy and update correctly on Feisty but not on Gutsy. Thanx Matt! I should have thought of that.


Top
Offline Profile  
 
 Post subject:
PostPosted: Wed Dec 05, 2007 9:42 pm 
Registered User
Registered  User

Joined: Wed Dec 05, 2007 9:38 pm
Posts: 2
nice


Top
Offline Profile  
 
 Post subject: Re: Wont run on Ubuntu Gusty
PostPosted: Mon May 12, 2014 8:16 am 
Registered User
Registered  User

Joined: Mon May 12, 2014 8:12 am
Posts: 0
Running into this same issue on Ubuntu 14.04. I've triple checked that the libraries are installed. After running the "ldd daphneloader.bin" command I'm seeing "not a dynamic executable" as a return.

I've tried redownloading the archive from the site and that did not solve the issue. Any advice on what to try next? I'm not seeing any log files generated so can't really tell what is going on in the black box.

Thanks!


Top
Offline Profile  
 
 Post subject: Re: Wont run on Ubuntu Gusty
PostPosted: Sun Jan 04, 2015 6:18 am 
DAPHNE Platinum Donator
DAPHNE Platinum Donator
User avatar

Joined: Wed Jan 31, 2007 3:26 am
Posts: 49
Location: Austin, Tx.
I was able to get it to run on Steam OS by installing build-essential. No luck in Ubuntu 14.04.
found this:
http://www.linux.org/threads/dragons-lair-space-ace-on-linux.6141/


Top
Offline Profile  
 
 Post subject: Re: Wont run on Ubuntu Gusty
PostPosted: Wed Mar 29, 2017 12:52 am 
Registered User
Registered  User

Joined: Sat Feb 25, 2017 2:54 pm
Posts: 6
I fought for weeks trying to get Mint 17 XFCE working.. here's what you need to do - Install emulation station core components and daphne. This will register all the libraries and everything you need to run daphne. Then you can just launch it from terminal. It was painful and a ton of google'n before I said forget it and just did the obvious.

done!

-rj


Top
Offline Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Theme created StylerBB.net